FANDOM


I had to get off earlier right in the middle of making the spoiler part, and hadnt checked when i started again, but it looks like you did a much better job than what i had so thanks Rune Farmer!! :D --DM 21:58, 16 Jun 2005 (EDT) and by the way my pics can be deleted so...


Admins, spam from Missy.

Map is Wrong

The three year old annotated map (specifically #4) got me stuck. The whole it says not to enter doesn't even exist anymore and the whole it said to go down got me to a dead end. PLEASE update it. OneGyT 02:46, 27 May 2008 (UTC)

"Spoiler" Title

The "Spoiler" title appeared twice in the beggening of the spoil. Problem fixed.


I've heard that the knight, instead of a sword could use a mace too. Can anyone confirm if this is true or just an hoax?

-- † Pudd Knight †  Talk  Contribs  -- 23:22, 24 June 2007 (PDT)

Someone should att the whole quest, as a old reference to what the quest was before the ending was spoiled, and as I recall all the books could not be collected from the library, but had to be accessed in different parts in the dungeon!


Yes, I once tried to start doing that but I didn't finish the original quest completely by myself. (didn't do the hall of lost doors part)

^^  º Bennie º  ¤ Talk ¤  º Credits º  ^^ 14:41, 20 February 2008 (UTC)


I did the quest something like this long time ago, hope this help in how to make it the real way: First find a scroll or book some where that talks abouth a guy that made a deal for a roll, then you have to find that guy, he is near the fire devils, then trade him a roll for a key (library key I think) after that you find that blind guy and you notice hes blind (lol) now you can go read the books which are funny and theres one that is for temporal visibility regain, then you get all the items in the book and go to the blind guy and heal him (he gives you another key), now you have this key you can use it for some door to get a (key or a book, I don't remenber well), you then need to find more books to solve the necromancer test to get the (key for the vocation teleport room I think), 1 book is in the fire devil pit (the key for that door is passing the bersekers you need to use a pick on a stone "the stone will hit you" after you break it theres a chess with the key for the pit, for the rest of the books... I don't remenber where they are but, maybe this places have them, theres a hiden lever behind a stonepile in the fire devil pit and a lever in the other side of the dungeon near the spike sword quest (theres maybe more hiden levers and i think you need to pull them at the same time), theres also a room that you need to make apear a bridge over the lava "maybe with those levers" and there is a room with rotworms and coffings and a hole which you can't reach cause theres a wall "maybe the levers again" also theres a TP and a lever too in the banshee room (again maybe those levers open the banshee or the bridge or the wall to get the other books in the dungeon), also maybe a book is in hall of lost doors? After you get all the books read them and pass the test you can enter the voc tps Druid face a bear, Sorcerer face some fire devils, Paladin some mino archers and Knight some orc bersekers, by walking there you can read which item you need, you get the items go to the final room and get the reward.

Now with these spoilers some one can have an idea how to make the quest, I would love to do it again (nor I remenber the exact way) it took me a week or more to finish it and I don't wan't to do all that again I will leave the job to some one else, some one that has never done this quest like this so he will enjoy more doing it and updating the article in a more acurated way. Hope some day CIP fix the quest and add quest flags in the npcs so people have to talk with them first before taking the 10k.
 Kwigon the sharpshooter   Talk   -March-05-2008.


The dessert quest now is Protection Zone as the two squares in the exit of the quest, cant be peked anymore, i dont know how to change this so i need someone do the change Cholo 21:01, 23 May 2009 (UTC)RoberpineCholo 21:01, 23 May 2009 (UTC)


Due to vandal edits all quest pages have been protected. Best thing to do is do what you did and leave a message on the talk page, then when an admin sees it they will make the edit. :) beejay 21:08, 23 May 2009 (UTC)

im still wating for a admin and thanks to beejay for the info, ADMINS modify this quest, or check yourself that now is a protection zone Cholo 17:02, 2 June 2009 (UTC)


Are you really sure it is protection zone? Isn't that something their gonna implement in the summer update? Can you say since which update/patch this is changed? ^^ Bennie (talk ~ fellows) ^^ 17:08, 2 June 2009 (UTC)


Its true that parts inside the desert dungeon are now a pz. I remember last time I went, I tried to attack my friend (up to the stairs) but kept "puffing". Not sure how long ago this was but it was within the last 12 months. beejay 17:45, 2 June 2009 (UTC)

I just had a quick look through the news archive and saw this: http://www.tibia.com/news/?subtopic=newsarchive&id=799&fbegind=3&fbeginm=5&fbeginy=2008&fendd=2&fendm=6&fendy=2009&flist=10111111

This could be when they introduced the protection zone in the desert dungeon, though I am not sure. I think I have only been to the quest once in the last year, and I doubt it was before the yalahar update. Hope that helps. :) beejay 21:14, 2 June 2009 (UTC)

i dont know in what update was implemented, but the only thing that i know is than the reward room and the two squares in the exit (outside) are Protection zones, i (with my brother) tried to kill the other 2 guys in the quest and we couldnt, then we tried to kill them outside and neither we couldnt. sorry for the bad english Cholo 03:30, 7 June 2009 (UTC)


That's mean :P I'll see what I can do to correct it for you. I'm quite surprised that CIP would put protection zone squares in the middle of nowhere—if a construction were built on those squares it would be acceptable, but now PZ-locked players will get quite the confusion when traversing the desert! -- Sixorish 04:13, 7 June 2009 (UTC)


That's why you get a little icon (like those crossed swords) when you are ON protection zone in next update, so you won't be confused. ^^ Bennie (talk ~ fellows) ^^ 06:45, 8 June 2009 (UTC)


how to get out

in this point:

4. Go up to the next elevation and follow the path. There will be a slime spawn to your right. Further to the north you will see a hole to the left. Do not fall into it, as there are Orc Warriors and Orc Berserkers down there. Keep going along the path and go up the last ladder at the end.

beside the hole theres a sign that you can read: Danger! Don't enter!

You cant go up by your self, you need help from other, but when you come out, theres a corridor of 1 square, so cant just walk back, yo have to go stright, and you find a small room with firefield above loose stone pile, and that;s all.

Someone know how to get out of there?


http://tibia.wikia.com/wiki/Mapper?coords=127.144-125.116-10-4-1-1&mark1=127.145-125.105-10-20&mark2=127.177-125.74-11-20&mark3=127.147-125.111-12-19

Follow the arrows down/up floors. Or in description if you can't load the mapper:

  • Go north where you fell down, down the hole,
  • Follow the cave to the north-east down (not up)
  • Follow the cave south (do not cross any bridges)
  • Go up and follow through the quest to the end.

-- Sixorish (talk) 07:27, April 19, 2013 (UTC)

I think you didn't understood where exactly I talking about...


Hmm I think you were at the wrong step in the spoiler. Down the hole you found a scorpion, right?

If so: http://tibia.wikia.com/wiki/Mapper?coords=127.140-125.121-11-4-1-1&mark1=127.149-125.122-11-20&mark2=127.148-125.111-12-19

  • Have someone rope you from the scorpion room.
  • Find the working hole beneath the fires.
  • Walk north-east and cross the bridge.
  • Walk south-west and go up the stairs. Follow the spoiler (you're at #2: Go up the ladder to the next map layer. Then go to the west and up again. Do not go down the hole to the south.

-- Sixorish (talk) 13:24, April 19, 2013 (UTC)

Community content is available under CC-BY-SA unless otherwise noted.