FANDOM


Old Talk

Am I going crazy or is there no Nightmare Knights outfit? I can only find the Brotherhood of BonesPerwik 05:56, May 1, 2010 (UTC)


Well if you're crazy so am i because i can't find it either xD

289martin289 07:28, May 1, 2010 (UTC)


There is no "Outfiter/Nightmare" page which is why there is no image and I don't know the code needed for the page. You could try asking User:Daniel Letalis nicely, maybe he will help you get the Nightmare Knights image. :) Beejay 13:15, May 1, 2010 (UTC)


I am having problems with outfiter after adding nightmare outfit, code is not being updated for non logged people, is just me ?

test link: http://tibia.wikia.com/wiki/Outfiter?o=23 --Daniel Letalis 05:34, June 29, 2010 (UTC)


I noticed that when I first went on it that it started at the wayfarer outfit, then I purged it and it went back to normal (starting at citizen). Both times the nightmare outfit was there I'm currently trying to see it on the browser Opera without being logged into TibiaWiki, the only thing it is doing is saying "Loading Outfiter", it has been like this for about three minutes now. Beejay 08:13, June 29, 2010 (UTC)



I think it is working fine now --Daniel Letalis 15:02, June 29, 2010 (UTC)

Tibian letters

Well. There are lots of alphabet letters in tibia. Is there anyone with time who can add them to code?
Ä Ë Ö Ó Ü
ß ä ë ó ö
and other letters writable in client?
There are still left characters with names like Bürgy and Kolskägg. So it can be useful for them.
Leree 16:16, December 9, 2010 (UTC)

Yalahari=mozilla crash

My Firefox tend to crash when about to load an image of Yalahari outfit. Somebody could maybe fix it.

Mule / donkey

Lionet said here that mule will be changed to donkey. I'm not sure if this applies to the mount, the creature, or both. -- Sixorish 03:08, July 5, 2011 (UTC)

Elementalist Outfit

There is bug with first female addon of elementalist outfit while being mounted and turned to north, colours are strange.
Dyror 11:28, July 17, 2011 (UTC)


I'm absolutely sure it is a tibia bug, too bad I can't test it :'( (the cap is so expensive now) I will extract the sprites again to test and even if it is a bug I think I've found what they did wrong so I probably can fix it later. --Daniel Letalis 01:32, July 19, 2011 (UTC)


It is a game bug, I'm not sure how it would look like in game because outfiter and tibia client process the images a bit different, I'm not a tutor but if someone wants to report it the incorrect sprite ids are: 51510,51514,51520 --Daniel Letalis 02:05, July 19, 2011 (UTC)


I can't check right now but I think helpers can still post on the test server board. Beejay 11:00, July 19, 2011 (UTC)

_____________________________________________________________________________________________

"NoName" Outfit

The "noname" outfit is epic, where is that from?

Zlebabb 13:11, December 25, 2011 (UTC)


Cipsoft sent fansites the new outfit images and did not give a name to the "no name" ones. Hunter of Dragoes inquired about the real name and the response is that the name is "secret" so players need to discover how to get it. Start searching!
Also, please refrain from using inappropriate language - we generally follow the Tibia Rules in this site.
--DM ><((°> Contribs <°))>< talk to me 16:05, December 25, 2011 (UTC)


Alright, my bad xd

So you're saying that the outfit has been implented in this update? I saw no CM's using it on the testserver, and neither have I seen any NPC using it. But that's really cool if they've implented it and if it's possible to get :D

Thanks man!


Yes it's new, and as far as I know they have only been seen in the sprites and nothing more is known about them. -- Sixorish 06:00, December 27, 2011 (UTC)

Barbarian (A)

Animation steps are bugged: http://tibia.wikia.com/wiki/Outfiter?o=106&f=2&aArkshi (Talk | contribs) 16:55, March 7, 2012 (UTC)


Should be fixed now. --Daniel Letalis 04:51, March 8, 2012 (UTC)

Can't Save Outfiter PNG Images

Hey I'm having some real trouble here, no matter what I try I can never save PNG images from the outfiter, I have no clue what I am doing wrong, I try saving it when I use "View Image", I try using "Save As" right from the outfiter itself and nothing works.

Each time I try I choose a place to save it (Like in My Documents folder), click Save, and then go look at the place I saved it and it's no where to found.

I'm currently using Mozilla Firefox to use the outfitter, as my Internet Explorer 8 is too old to use the Outfiter (apparently).

Can anyone tell me what I am doing wrong? I just don't understand how the saved images are not showing up on my PC when i save, I am having this issue with both animated and non-animated PNG images.

- Jake

Only internet explorer 9(windows 7?) can? show Outfiter.

I don't have any problem here saving images with firefox 12.0, as well in other browsers, 1 thing you can try is to disable the animation(because only few programs play animated pngs) or enable the option "show animation steps", and save the images(steps) from right below the outfiter window.

--Daniel Letalis 05:13, May 17, 2012 (UTC)

Dimensions

All animated outfits are generating 65x64 "soft" images, should they be 64x64 (same as in sprites)? (using Firefox 13) -- Sixorish (talk) 01:45, July 6, 2012 (UTC)


Yes they should be, I remember noticing this some time when coding the bar and name but couldn't find the problem easily so I just let it be. I would fix this if needed but I don't think it is because we usually crop npcs and outfits images. --Daniel Letalis (talk) 02:28, July 11, 2012 (UTC)

Bug with gnome

There was a bug on "9.6 gnome" on test server, the front part of the hat shouldn't be red. I want to fix this but the spam filter doesn't let me, just letting you know if you will make some npc image, so maybe you wait. --Daniel Letalis (talk) 02:28, July 11, 2012 (UTC) LOOOOOOOOOOOOOL the cloned wiki that complains about us using their content has the bug on their images. --Daniel Letalis (talk) 02:41, July 11, 2012 (UTC)


You mean Portaltibia? Tibia-wiki? I don't remember any wiki complaining ...

Is it something we can fix? Or Wikia's spam filter? I thought you meant our abusefilter but it has nothing in the logs. -- Sixorish (talk) 02:51, July 11, 2012 (UTC)


About the complains, nevermind.

Nothing we can fix, was wikia spam filter, it seems they added the filter recently so I reported it, still waiting for an answer. --Daniel Letalis (talk) 03:53, July 11, 2012 (UTC)

Gnome might not work for now on some browsers, will be fixed when I manage to workaround the wikia spam filter or rewrite the css code on outfiter :x --Daniel Letalis (talk) 11:13, July 13, 2012 (UTC)


What do you mean with wikia spam filter? Did you ask to create this: MediaWiki:Outfiter.css? I'm just curious :) -- Bennie (talk ~ fellows) 16:45, July 13, 2012 (UTC)


I use base64 encoded images on most CSS code I created(an all outfits/mounts), it is not possible anymore to add this images on wikia with images that are bigger than 75 bytes (100 characters on base 64 encoded data) because strings bigger than 99 chars are blocked by wikia spam filer(even being an admin you can't skip this, wtf), they created the page because they thought I only needed that single code, and they said I have to ask to them everytime I want that page modified. Some browsers recognize correctly base64 encoded data with spaces, but according to wikipedia some browsers don't. So I have to work around this so I don't have to ask them every time I make a css change, and wait that they do it. I will just put the base 64 data with spaces on javascript code, then make the javascript remove the spaces. This same limitation happens with all the outfits and mounts data, will workaround it the same way. I thought it was gonna be hard but I think it will be simpler than this explanation, haha. --Daniel Letalis (talk) 06:02, July 14, 2012 (UTC)


Wow, that's a smart workaround (add spaces and remove it with js). A better thing would be to ask them to remove this spam filter for admins. Wikia shouldn't limit us this way. Let me know if you need help asking this. -- Bennie (talk ~ fellows) 08:23, July 14, 2012 (UTC)


I don't think they can or are willing to remove the limitation, but it would be great for future edits. --Daniel Letalis (talk) 20:27, July 15, 2012 (UTC)

Gnome

Maybe they changed it in the recent patch but some pixels are off?

I can't get a 100% accurate image with this.

Test-Gnomole

"Primary" is the torso and part of the hat. Its color is accurate in the torso but not part of the hat. Also, the name is shifted by 1-2px but that's not a major problem. -- Sixorish (talk) 00:35, August 11, 2012 (UTC)


The hat of male gnome facing 3 of 4 directions has bug in tibia clients, I reported it in test server but was not fixed, then I told to a tutor and he reported it few weeks ago, it was not fixed in the latest tibia patch. I fixed it on outfiter since I added it because I thought they were gonna fix it soon. I can edit the outfiter code and add the bugged images if you think it is needed but I would do it in 4 or 5 days. --Daniel Letalis (talk) 01:18, August 11, 2012 (UTC)


Hmm, it's ok then as it is. Should we use the 'bugfix' version or the in-game version for the NPC image? -- Sixorish (talk) 01:32, August 11, 2012 (UTC)


Nvm, I'll upload the in-game sprite and add a link to the outfiter. -- Sixorish (talk) 01:59, August 11, 2012 (UTC)

Wikia skin

Outfiter is not displaying correctly nor loading on wikia skin: OutfiterArkshi (Talk | contribs) 22:16, September 22, 2012 (UTC)


I tried it on IE9, Firefox and Chrome thinking it was a problem with the browser but none of them worked either

Aaronconlin (talk) 03:29, September 23, 2012 (UTC)


I will (try to) apply a fix, although I'm not sure why the code worked before. I figured it would be something Wikia changed but unless the jQuery version has changed, it shouldn't have worked when it was coded... -- Sixorish (talk) 05:13, September 23, 2012 (UTC)


Yeah jQuery version changed from 1.7.2 (current on monobook), to 1.8.1 (current on wikia). I guess that's why. -- Sixorish (talk) 05:29, September 23, 2012 (UTC)

Female demon detail?

Am I crazy or does the detail on the female demon outfit not work? I'm not sure as I haven't seen the outfit in-game on a female yet, but the trim of the outfit is always white and when I change the detail colour nothing changes on the outfit.

The legendary orp (talk) 04:11, December 23, 2012 (UTC)


If it's a bug I think it is with the official sprites. Check out the FC sprites:

http://static.tibia.com/flash-regular-data/1355229258-sprites_1610630144.png
http://static.tibia.com/flash-regular-data/1355229258-sprites_1610630400.png

Notice there's no blue in the female color mapping while there is on the male's. -- Sixorish (talk) 11:29, December 23, 2012 (UTC)

Glooth Engineer Outfit?

The update has been out for a month and the new outfit still isn't on here. Wondering why? The legendary orp (talk) 02:08, August 9, 2014 (UTC)


It was missing because you didn't ask :) Try it now and see if all looks well. --DM ><((°> Contribs <°))>< talk to me 04:48, August 9, 2014 (UTC)

Beastmaster / Conjurer / Champion

Daniel's site appears to be down otherwise i would have gotten images for 3 new outfits. For now i have started piecing them together from the 16 images i found (starts with sprites-f6457e7b510a595bd3cff0d4263ee5fba63289d49d0ba6b78b31b1a0514bd1f6.png) but if someone has script he used to put them altogether then please let me know. I will try to finish tomorrow or this weekend when i find some more time. --DM ><((°> Contribs <°))>< talk to me 03:13, September 5, 2014 (UTC)


I added the missing mounts and outfits, also the site dat reader is up again. --Daniel Letalis (talk) 04:21, September 16, 2014 (UTC)

Conjurer Female

When you face south as Female Conjurer in all variations(no addon, 1st addon, 2nd addon, both addons), the gifs are 63x64, could that be fixed?


Thanks for reporting, I'll look into it when I can, hopefully soon. --Daniel Letalis (talk) 03:20, October 18, 2014 (UTC)

Chrome issue on Chaos Acolyte outfits

Right now there is an issue with latest chrome and Chaos Acolyte outfits. If you want to see the images correctly, use another browser.

Because these outfits have more sprites (standing animations), the spritesheet I'm using for them is taller (512 x 6144 pixels), I believe this is causing chrome to add some noise to the images.

I'll try to workaround this soon. --Daniel Letalis (talk) 01:09, December 6, 2014 (UTC)

Other with Addons but no Mount

Outfiter > 862

Seems like our outfiter doesn't allow for this kind of combination for some reason.

Solutions:

  • someone fixes/modifies the code(yes plx plx plx)
  • try adding it as Male outfit
  • merge sprites of outfit and addons in different combination and add as 4 possitions (boring and long, pls no)

Could anyone help out? Thanks.

Cauli92 (talk) 20:51, November 12, 2015 (UTC)


I've applied a fix, you can now set whether an outfit has no ride frames within the code. Let me know if you encounter any issues since the change. -- Sixorish (talk) 04:07, November 13, 2015 (UTC)


Hey! Thanks a lot!
Seems like there was also an issue with my cookies or something else in history, so I kept seeing bugged animation until I cleaned them, but now it works perfectly, thank you again!

Cauli92 (talk) 07:26, November 13, 2015 (UTC)

Winter Update 2015 - Names

I don't think I will have enough time to find out the names of new outfits and mounts, so if anyone gets to know them, please write them down in here:

  • 845 - Female Rift Warrior Outfit
  • 848 - Rift Runner
  • 849 - Nightdweller
  • 850 - Frostflare
  • 851 - Cinderhoof
  • 852 - Female Winter Warden Outfit

—The preceding unsigned comment was added by Cauli92 (talkcontribs). Remember to sign your comments!


I know names have been fixed a long time ago, but I just answered your question. :)

Hunter of Dragoes (Talk · Contribs · Admins) - 22:03, May 1, 2016 (UTC)

Retro Female Mage Outfit

Hey Guys, I had a little problem with retro female mage outfit - no matter how many times I tried to download sprites and update the reader, this outfit appears to be broken. I would highly appreciate if someone could confirm it's indeed a case or if anyone could upload a proper image if it's not. For now I've assigned Retro Mage outfit to 'only-male' outfits in the Outfiter.

Thanks in advance
Cauli92 (talk) 09:35, May 26, 2017 (UTC)


I noticed that problem two weeks ago, asked Cip about it, but didn't get a reply. I just asked again. I'll let you know when I hear from them.

Hunter of Dragoes (Talk · Contribs · Admins) - 13:44, May 26, 2017 (UTC)


I've found where exactly the bug was and reported it. I was told the bug fix is ready to go online. We should check after the next client update or try to manually fix the spritesheet by removing the blank lines.

Hunter of Dragoes (Talk · Contribs · Admins) - 01:19, May 30, 2017 (UTC)


Hey Hunter,
Thanks for all the info! I was considering making the sheet "manually", but it's not just the blank lines - it's one outfit being mixed up in the sprites, so I wouldn't only have to remove the lines, but cut the pieces here and there and hope I did everything properly, else the whole work is gonna have to be re-done. It's not massive amount of work, but since they already have the fix ready, I'd just we just wait for it.
mixed outfits - last line
bugged parts of colour sprites - parts of earlier ones - 3rd line

Cauli92 (talk) 14:24, May 30, 2017 (UTC)


What do you mean by "mixed outfits"? As far as I can see, the last 4 (female retro mage) mask sprites shouldn't be there. One is a duplicate of another sprite, while the others are pieces of other sprites. I can't see what is wrong in the first spritesheet you linked to.

Hunter of Dragoes (Talk · Contribs · Admins) - 17:00, May 30, 2017 (UTC)


It seems it was fixed with Update 11.43.5504. I already added it to the Outfiter.

Hunter of Dragoes (Talk · Contribs · Admins) - 18:56, August 22, 2017 (UTC)

Missing Mount and Outfits

Arctic Unicorn, Blazing Unicorn, Festive Outfits, Grove Keeper Outfits, Pharaoh Outfits, Prismatic Unicorn, Stone Rhino (Mount) and Trophy Hunter Outfits + monster outfits #932, 935, 947, 980 + unknown outfits #1020-1021 still need to be added to the Outfiter.

Hunter of Dragoes (Talk · Contribs · Admins) - 18:27, June 20, 2017 (UTC)


I decided to give this a try with Stone Rhino, but there's no tutorial, haha. I created Outfiter/Mount/Stone_Rhino and added the base64 code from the sprites I extracted and then pasted into one single file. One thing that I'm not sure is correct is that the sprite sheets only have 6x6 sprites for this mount, and all others I converted from base64 to png have 12x6. Not sure if the code required every sprite twice or it's jut a matter of number of different frames.

Still, I cannot update Outfiter/Code and apparently the mount name must be added there for it to load. If you could try testing that it would be awesome. If it works I can try the other missing outfits and mounts too.

Molx (talk) 19:11, August 21, 2017 (UTC)


I had to change Outfiter/Mount/Stone Rhino in order for it to work. But thanks for giving it a try!

Hunter of Dragoes (Talk · Contribs · Admins) - 21:13, August 21, 2017 (UTC)


I found out how and created a way to generate the (apparently) correct sheets for outfits that repeat sprites such as #947 (The First Dragon). I also created sheets for the other missing creatures:

If the First Dragon turns out to be correct we can work on that outfit you mentioned had some issues because of effects/animations. Let me know if you need details about how I did it. Molx (talk) 04:30, August 26, 2017 (UTC)


Ok, here's another round:

According to Hunter's list only Trophy Hunter Outfits should be missing now.

Molx (talk) 19:13, August 27, 2017 (UTC)


Good job, Molx! All done except Outfiter/Male/Trophy Hunter which I couldn't create because it triggers a spam filter.

We could also add the new unknown outfits to the Outfiter and just rename them when more info is found.

Oh, and some mount and outfit pages still need to be created.

Hunter of Dragoes (Talk · Contribs · Admins) - 01:24, August 28, 2017 (UTC)


Upon my request, the spam filter was removed by the Spam Task Force. I just added Trophy Hunter Outfits to the Outfiter.

Hunter of Dragoes (Talk · Contribs · Admins) - 13:36, August 28, 2017 (UTC)


It seems our Outfiter code is not ready to deal with outfit spritesheets with duplicated sprites such as The First Dragon. It can be fixed manually, though.

Hunter of Dragoes (Talk · Contribs · Admins) - 14:22, August 28, 2017 (UTC)


I think I might have done something wrong with The First Dragon. Pharaoh and Grove Keeper also have repeated sprites and they are working fine. I suppose that once the sheet is generate the Outfiter only cares about individual sprites order and doesn't even "known" some are repeated. I can't know but I will check it carefully later.

I didn't think Admins were also blocked by the spam filter, that's unexpected, haha. I created Festive Outfits (sorry about the wrong name with the outfiter pages, by the way). Festive Outfits Quest is still missing though, I didn't do this quest so I rather not create the page. I also did not find proper artwork for it in the Anniversary News. Maybe you can get one from Rejana?

Molx (talk) 17:12, August 28, 2017 (UTC)


I've generated a spritesheet for The First Dragon outfit myself, but it didn't work either. I don't know what's wrong with it either.

The spam filter that blocked me was one applied by FANDOM on all wikis. The spam filters created by TibiaWiki admins don't block ourselves, if we've coded it right ;). Thanks for creating the missing mount and outfit pages. I don't believe there is an official artwork for the Festive Outfits.

Hunter of Dragoes (Talk · Contribs · Admins) - 20:12, August 28, 2017 (UTC)


Outfiter/Female/1020 and Outfiter/Male/1021 are ready.

I think I may have found out the problem with The First Dragon. You have added it to outfiter_no_ride_names, but looking at the .dat it has z = 2, which means that for some reason it has a "Mounted" version. If you look at sprites #55101 and #55125 you'll notice they are (supposedly) identical, which I assume is the standing version for both z's. It's moving all weird in the Outfiter because it's using this standing sprite of z=2 in the animation. Fun thing: It looks like sprite #55125 has a small error, there are 4 extra pink pixels on the tail. I think it's a bug so I'll report it, haha.

Molx (talk) 00:37, August 29, 2017 (UTC)


You're right. It seems a creature with such outfit could be mounted, lol. I'll remove it from outfiter_no_ride_names while keeping it on outfiter_m_names. It will hopefully solve the bug and not let someone preview how a mounted First Dragon would look like (haha).

Hunter of Dragoes (Talk · Contribs · Admins) - 01:48, August 29, 2017 (UTC)


Yes, it is working as intended now. Thanks for the tip!

By the way, the bug is not only with sprite #55125, but many of its mounted sprite versions have non-transparent pink pixels.

Hunter of Dragoes (Talk · Contribs · Admins) - 01:51, August 29, 2017 (UTC)


New, unknown outfits have been added to Outfiter.

Hunter of Dragoes (Talk · Contribs · Admins) - 03:38, August 29, 2017 (UTC)

Community content is available under CC-BY-SA unless otherwise noted.