Links for accessibility:

Creatures spawns

Is it senseful to make a map with spawn of certain creature? For example - spawn of dragons in Zao mountains (marked with 1 kind of mark) + spawn of DLs (another kind of mark) and so on?

Jura 19:45, August 9, 2010 (UTC)

Coordinate separator

I tried to link to the PoI shortcut doors on the Tibia forums but the comma causes it to produce the warning message before it:

'http://tibia.wikia.com/wiki/Mapper?coords=128.57 [Do not look at external websites. Your account could be hacked.],126.77,11,8,1,1

Should this take another coordinate separator? -- Sixorish 06:50, August 11, 2011 (UTC)

I think links are only parsed on Private forums that are used only by tutors? and CMs, for regular users you only need to disable the links parser when doing your post by unchecking "Automatically Parse URLs", that would be a temporarily solution.

I think mapper could be changed to use "-" because it is a url friendly character, mapper will be backwards compatible to process comma links too. I will change it in 1 or 2 days. --Daniel Letalis 04:22, August 12, 2011 (UTC)

Coordinates bug


The mapper generates this link with the coordinates 131.25,121.229,15, but the popup minimap uses the coordinates 127.25,121.229,15. First is at the ramp beneath the deepling spawns (soul net mission) and second is ... a bit north from Fenrock dragon lair. -- Sixorish 16:18, April 26, 2012 (UTC)

Fixed now, I discovered it today too. --Daniel Letalis 19:33, April 26, 2012 (UTC)

Mapper updated 200120713

I updated the mapper 20012 - 07 - 13

I changed GIFs for more compressed PNGs, if anyone has issues with them let me know.

I uploaded maps for tibia c++ client, generated from Mapper images here:

--Daniel Letalis (talk) 12:14, July 13, 2012 (UTC)

Kinda weird, this isn't updating for me to include the new areas (popup mapper is fine). -- Sixorish (talk) 07:05, July 20, 2012 (UTC)

Nvm, found it, was using the old gifs. -- Sixorish (talk) 07:14, July 20, 2012 (UTC)

Old mapper files

I've been looking for old versions of the mapper images (such as File:Minimap Floor 7.png) but the file history only shows the current version. Have them been deleted? Is there a way to see old versions?

Thanks! —Arkshi (Talk | contribs) 01:18, October 8, 2012 (UTC)

They were gifs before (see above section). Replace '.png' with '.gif' to get the old revisions. They were apparently deleted as well, but you're an admin so you can get those files. -- Sixorish (talk) 02:48, October 8, 2012 (UTC)

Yep, I'm able to see them. Thank you. —Arkshi (Talk | contribs) 15:21, October 8, 2012 (UTC)

Maps still needed

Please add to this list if you see places that might be accessible but we don't have maps there, or where our maps are incomplete or out of date.

-- Sixorish (talk) 03:07, January 15, 2013 (UTC)

These are the two I found so far. The place near Corym cave that you pinned is unreachable, it's that room that shows the broken dream machine.
Edit: also this area in the same PoI maze that you mentioned above.
Art Featherpitch (talk) 08:35, January 15, 2013 (UTC)

  • It looks there is a (inaccessible?) cave here. You can see parts of its "walls" on the current map.
    Arkshi 11:14, January 15, 2013 (UTC)
  • Yes, there seems to be a whole cave around the -3 level of the Venore Salamander Cave there. Isn't that just a part of unmapped Corym cave? -- Bennie (talk ~ fellows) 11:32, January 15, 2013 (UTC)

The system works! I missed a part of the salamander cave, it will be up soon. I removed the dream machine and added the shadows of yalahar quest area. If I find time tomorrow I will map the shadows of yalahar quest area. Also I got warzone 1, will try to get 2 tomorrow too.

Regarding the lizard prison, yeah I'm fairly certain we have all we can get there. -- Sixorish (talk) 12:30, January 15, 2013 (UTC)

  • Added this one - does anyone know where or what that is?
It looks like a map bug to me, I've checked 4 other fansites with maps and only one (guess which!) of them shows this same area.
Arkshi 17:30, January 15, 2013 (UTC)
If you look 2 floors above that area, you notice it is a replica of a part of the Edron rotworm cave, only with no gray floor (this was added in a revamp). Most likely, somebody who assembled the map accidentally pasted part of the cave on the wrong floor.
Art Featherpitch (talk) 08:36, January 16, 2013 (UTC)

And is this place accessible? Doesn't look familiar. -- Sixorish (talk) 13:38, January 15, 2013 (UTC)

That's the final room of The Elemental Spheres Quest.
Art Featherpitch (talk) 15:33, January 15, 2013 (UTC)

What about this north of warzone 3? Those 1 sqm rooms clearly looks inaccessible for me. Do anyone know what they are?
Arkshi 17:30, January 15, 2013 (UTC)

@Arkshi: on the TS warzones were introduced, we had a bug where the warzone teleports would not take us to the boss room but take us to either of those tiles where we could not move, and we'd be kicked offline a second later (and log in temple). I think it's meant to be a 'fall back' location where we end up if something goes wrong. -- Sixorish (talk) 20:44, January 15, 2013 (UTC)

Added to mapper files:
- missing part of salamander cave,
- PoI maze,
- Shadows of Yalahar golem head quest area,
- All of warzone 1, some of 2
-- Sixorish (talk) 03:04, January 16, 2013 (UTC)

Windows 8 Mapper Bug

A few days ago I upgraded to Windows 8. I see a bug (shifted navigation thing) on the Mapper article:


This happens with Google Chrome and Firefox (newest versions) but not to Internet Explorer 10, with Windows 8 Pro (x64). I think it has to do with Windows 8 making insert boxes larger, so you would be able to use them with a touchscreen better. -- Bennie (talk ~ fellows) 13:26, January 15, 2013 (UTC)

Try Mapper/Test. I replaced the input boxes with divs, if that's the problem it should be normal there.

Edit: should mention, use &useskin=monobook because Wikia's skin doesn't use common.js and I don't feel like maintaining 2 for testing...if it works on monobook it should work on wikia (given the wikia.js changes), unless wikia has defined styles for <input>. -- Sixorish (talk) 15:32, January 15, 2013 (UTC)

Yeah, that fixes the problem. Great job! :)

Edit: btw, Wikia's skin does use common.js, at least I can confirm it for this case and I also put the js code for the custom spoiler there and it works on Oasis as well. -- Bennie (talk ~ fellows) 16:03, January 15, 2013 (UTC)

Maybe you could download Firebug and check for styles Wikia applies to the input buttons, because I don't think the change in OS will do that (more likely, Wikia has different styles for touchscreens). We can override Wikia default css, without introducing new bugs with old browsers which don't support float properly. -- Sixorish (talk) 16:26, January 15, 2013 (UTC)

Missing in 9.86

Please list anything that might be missing in the map as of 9.86. I didn't explore all of Svargrond glacier so I may have missed something there. -- Sixorish (talk) 16:23, April 27, 2013 (UTC)


Mapper updates in 10.2:

  • Upper spike (floor 1, 2, 3) - done
  • Middle spike (floor 4, 5) - done
  • Lower spike (6, 7, 8) - done
  • Drefia The Pale Count lair - done
  • Tiquanda The Welter lair - done
  • Spirit grounds - done
  • ???
  • Fury dungeon (Furyosa? not sure if needed)

Please add if you know places expanded. -- Sixorish (talk) 12:46, September 11, 2013 (UTC)

Wikia change broke it

Anons who try to load this page will have the following error logged to the console:

SyntaxError: missing ) after condition
...tmpp = tmpp.split(/[,-]/)).length &lt; 3) { pars = [127, 128, 124, 128, 7, 1, 1,...

I think Wikia changed it so that anonymous users cannot use the ?action=raw query anymore, so MediaWiki:Common.js is loading the actual page with ?action=view. I don't see why they would do this... -- Sixorish (talk) 15:40, October 22, 2013 (UTC)

I don't see any errors using windows 8.1 pro preview, ie 10 (or 11?) as anon.. -- Bennie (talk ~ fellows) 21:58, October 22, 2013 (UTC)

I don't get an issue with loading Mapper logged out on chrome (I use firefox). Although I have noticed that either logged in or out with chrome and firefox, I get an issue with clicking on Mapper on the search. It would appear to be something to do with the Mapper icon link as Map on there works. Beejay (talk) 22:22, October 22, 2013 (UTC)

Wikia responded and could not reproduce it. I've had 5~ people come to me in-game saying the mapper would not work but I couldn't reproduce it either until I viewed it on IE.

These are the files I have tried to view with ?action=raw

  1. http://tibia.wikia.com/index.php?title=Mapper/Code&action=raw
  2. http://tibia.wikia.com/index.php?title=Mapper&action=raw

The first one would not work on IE, the second would work just fine.

When logged out of Firefox but on the same profile, the mapper still worked. On a fresh profile however, with a clear cache and no cookies, the mapper stops working. Exact same behavior as IE has. Both of these browsers can load (2) just fine, just not (1), and Outfiter/Code works fine with ?action=raw as well.

-- Sixorish (talk) 00:06, October 23, 2013 (UTC)

It won't load using a clean profile on Firefox for me as well. — Arkshi 00:31, October 23, 2013 (UTC)

There were quite a few people having problems when I asked in my server's English chat. I haven't figured out what the problem is, since it does not occur for everyone. I asked 2 friends to try on a clear Firefox profile, using Win7, and none of them had this problem. But in English chat today someone had a problem with it on Win7.

Maybe one of Wikia's CDNs have a bad cache or something, because it seems to be cross-browser and cross-platform... -- Sixorish (talk) 00:48, October 23, 2013 (UTC)

Kirkburn can reproduce it now.

It doesn't matter if you are logged in or not as I initially expected. Anyone who has a clear browser cache will have this problem.

The reason it is working is actually because I have a cached version, and I guess the reason few others can readily reproduce it is because the way the script is generated means the Mapper/Code page is not purged from the browser cache with ctrl+F5. -- Sixorish (talk) 04:00, October 24, 2013 (UTC)

Did Kirkburn comment on any update/code change at Wikia's end which could have caused this bug to arise now? -- Bennie (talk ~ fellows) 14:16, October 24, 2013 (UTC)

Missing in 10.3

  • When the update passes, we need CipSoft's surface map for the new area.
  • On TS ever since it went public the sight of surrender area has been inaccessible. We need the entire area there.
  • The north-eastern Shiversleep maze has an unmapped area. So far I couldn't figure out how to get there.
  • We may be missing some quest areas. I didn't do much questing and I did receive a lot of messages telling me I needed to do something first.

-- Sixorish (talk) 01:11, December 6, 2013 (UTC)

Locations I couldn't find entrances to:

-- Sixorish (talk) 00:01, December 7, 2013 (UTC)


It's been over a day now and the server's cache for the map images have not been updated... The template version of this works fine because it loads an up-to-date filepath. I'm wondering if we should use a similar method, e.g. by displaying the images and letting the server decide the URLs instead of hard-coding them. At the moment the only way I can use the mapper with the new area is by adding a ?nocache= query to each of the URLs in minimap_images (this seems to imply a client-side cache, but it happens even on a clear cache...there's no way we can purge the server's cache of a single file). -- Sixorish (talk) 04:13, December 7, 2013 (UTC)

Floating div issue

Wikia's LazyLoader feature seems to make Template:Minimap load poorly or not at all. I've noticed that I have to scroll down a fair bit below the map itself before it loads. I wonder if this could be fixed by using background-image instead of an image? Is there a technical reason why background-image won't work? Maybe it can be used in conjunction with the current way because some browsers don't support background-size. -- Sixorish (talk) 10:17, January 13, 2014 (UTC)

Lack of support for background-size is the main reason, wiki resized images like this could be used: http://static2.wikia.nocookie.net/tibia/en/images/thumb/6/64/Minimap_Floor_7.png/614px-Minimap_Floor_7.png BUT wikia has restrictions with css image background, I believe it is related to images being on a different subdomain than the wiki.

Besides changing wikia php code or removing lazy load on all the site, the only option would be to use javascript with a "non enabled javascript fallback", also it would require Template:Minimap to be protected. I will look into this soon.

--Daniel Letalis (talk) 16:58, February 1, 2014 (UTC)

To-do (2014 pre-update)

-- Sixorish (talk) 09:33, May 28, 2014 (UTC)

If I remember correctly that PoI place is right before Bazir's throneroom, you get teleported there if you do something wrong during the quest. — Arkshi 02:20, May 30, 2014 (UTC)

Arkshi, i never did PoI but i remember that room from a video and i think what you said is correct. --DM ><((°> Contribs <°))>< talk to me 23:58, July 20, 2014 (UTC)

I've explored that area a lot and went to many places but this was not one of them. The levers in the maze are either duds, open teleports/doors or seem to do nothing. The tiles in the throneroom either take you to the main room or take you to a small circular room with many shooting pillars, or take you toward the throne. The teleporters (2) either take you to the quest area or take you outside a door just above it. I have explored it a fair bit but never saw this place. Unless the levers change the teleporter functions I really don't know. -- Sixorish-Safe (talk) 07:42, September 20, 2014 (UTC)

Oramond Update 10.5

First off, thanks to Giankk for helping with maps. We still have some gaps left, noted below:

--DM ><((°> Contribs <°))>< talk to me 23:58, July 20, 2014 (UTC)

I got the abandonded sewers partly: https://dl.dropboxusercontent.com/u/14919964/tibia/abandoned%20sewers%20%28partly%29.png -- Bennie (talk ~ fellows) 06:44, July 21, 2014 (UTC)

If you guys need some areas mapped just send me a messnage on the talk page i probobly have everything you could ask for and if not i get it! exploring maps is my life in Tibia haha

https://dl.dropboxusercontent.com/u/50765870/Tibia_All_Floors_PNG.zip    Png images of all floors that i got explored i might have some stuff you dont on oramond .. and maybe somewhere else to no idea.. enjoy

Blue Tome.gif Ayuki - Talk Blue Tome.gif 10:06, July 21, 2014 (UTC)

Thanks guys. It looks like all the big missing areas are covered, as well as some small tweaks in other places. Now we just need to add mapper links to NPCs/buildings/quests/etc. --DM ><((°> Contribs <°))>< talk to me 01:51, July 22, 2014 (UTC)

Glad i could help :)
Blue Tome.gif Ayuki - Talk Blue Tome.gif 03:31, July 22, 2014 (UTC)

Assistance needed - Dawnport

Could an administrator please upload these files over the originals?

  1. File:Minimap Floor 8 Temp.png over File:Minimap Floor 8.png
  2. File:Minimap Floor 9 Temp.png over File:Minimap Floor 9.png
  3. File:Minimap Floor 10 Temp.png over File:Minimap Floor 10.png

These files have Dawnport I think fully explored. It looks like someone else already added the floors from surface up.

Thanks, -- Sixorish-Safe (talk) 07:46, September 20, 2014 (UTC)

Sure, what happened to User:Sixorish? -- Bennie (talk ~ fellows) 10:18, September 20, 2014 (UTC)

I am using a laptop which may not be secure so I'd rather not risk User:Sixorish (hence, Sixorish-Safe).

Thanks for uploading those files. -- Sixorish-Safe (talk) 10:54, September 20, 2014 (UTC)

Missing in 10.7

I have updated the maps to 10.7. Please add mapper links where you can.

Missing areas on the map:

-- Sixorish (talk) 18:42, November 28, 2014 (UTC)

I mapped some of the western seacrest grounds which could be added to the mapper. I did it on the flash client though, what is the easiest way to add it? Screenshot my minimap piece by piece and merge the images? -- Bennie (talk ~ fellows) 19:05, November 28, 2014 (UTC)

That's weird. I mapped all of that at one point but I guess my map didn't save for some reason. I will get it tomorrow, no problem. -- Sixorish (talk) 19:18, November 28, 2014 (UTC)

Let me know if you find anything else unmapped. If one of my mapping sessions went unsaved then there's probably a lot more missing. -- Sixorish (talk) 05:11, November 29, 2014 (UTC)

Hey Bennie,

I checked it out and couldn't find anything unmapped that can be mapped. Regarding your edit summary, slab 2 is mapped here and slab 1 is mapped here. If you have any idea how to map the area north of slab 1 I'd love to know...but I can't find any way over there. -- Sixorish (talk) 07:08, November 29, 2014 (UTC)

Ok thanks, I added routes to slab 1 and 2. I tried but can't find a way to that unmapped area either. I actually assumed it was a quest area for the fire-feathered part. -- Bennie (talk ~ fellows) 11:19, November 29, 2014 (UTC)

I think all is done and added to the mapper except the last parts of the Hero of Rathleton Quest, which are here. I think this will have to wait until the update goes live unless someone else has those maps. -- Sixorish (talk) 11:19, December 4, 2014 (UTC)

As a side note, I'm not sure what we should do about the world change there. The mapper is often used to make routes and such which doesn't work very effectively if the world change shifts the environment such that some paths become "blocked". -- Sixorish (talk) 11:30, December 4, 2014 (UTC)

Alternate coordinate numbers?

I noticed TibiaWiki.com.br and most other sites use different numbers for the coordinates. NPC Grizzly Adams is:


…but on TibiaWiki.com.br the numbers are different:


Is there any way to convert from one format to the other?

Mathias (profile, talk) 14:06, June 23, 2015 (UTC)

The systems are different. Ours follows the .map files you store in your %AppData% directory, theirs follow the actual in-game packet data.

To convert to their system:

x=x1 * 256 + x2
x=127 * 256 + 182
y=y1 * 256 + y2
y=128 * 256 + 1

To convert from theirs to ours:

x=floor(x / 256) . (x mod 256)
floor(32694 / 256) . (32694 mod 256)
127 + . + 182 → 127.182
y=floor(y / 256) . (y mod 256)
floor(32772 / 256) . (32772 mod 256)
128 + . + 4 → 128.4
z=6 [note that their map displays the wrong level]


  • Each map file contains data for 256 x 256 x 1.
  • The number after the decimal represents the x and y component in the 256x256 grid. This is why you can't get e.g. 127.562.
  • The number before the decimal represents the map filename component.
  • You might have a map file called: 12412707.map. This means it covers 256x256x1 from (124*256, 127*256, 7) to (125*257-1, 128*256-1, 7).

Their system is better but we have what we have I suppose. -- Sixorish (talk) 01:09, June 24, 2015 (UTC)

Thanks for the detailed info! Much appreciated.

Mathias (profile, talk) 08:18, June 25, 2015 (UTC)

As a follow-up: `Tibia.exp` (i.e. exported maps from the C++ client to the Flash client) use the in-game packet notation as well. I found this interesting, as the C++ *.map files are named differently.

Mathias (profile, talk) 10:45, July 9, 2015 (UTC)

Feel free to use images from the tibia-map-data project!

I've started an open-source project called tibia-map-data where the community can submit new map data and markers. https://github.com/tibiamaps/tibia-map-data

Feel free to use the generated images for the Mapper. The files are here: https://github.com/tibiamaps/tibia-map-data/tree/gh-pages/data

Mathias (profile, talk) 21:04, July 11, 2015 (UTC)

Look really good. Do you mind me using your code as a reference for a similar project I am working on? In particular I may need to create *.map files but I'm not versed in the *.map file format. -- Sixorish (talk) 08:52, July 12, 2015 (UTC)

I have not looked to closely into this yet but by chance would either of your work involve/allow for a new/updated version of TibiaMapViwer? I tried a few ways to recode it a year or two ago but never finished. --DM ><((°> Contribs <°))>< talk to me 21:03, July 12, 2015 (UTC)

@Sixorish: Go ahead! I hope you'll open-source your project as well, though ;)

@DM: Do you mean http://tmviewer.sourceforge.net/? I haven't had time to look at how it's coded. Maybe you could open-source your recoding attempts (I'd recommend GitHub) so people can help?

Mathias (profile, talk) 07:19, July 13, 2015 (UTC)

Haven't Daniel recoded TMV a few years ago?
I remember he fixed the bug of wrong display colour for snow (should be white, but was black, if I remember well).
I even remember an image-to-map convert feature, but I might be mistaken.

Hunter of Dragoes (Talk · Contribs · Admins) - 22:37, July 26, 2015 (UTC)

Any image-to-map conversion wouldn’t include the pathfinding data that the Tibia client creates, though.

Here’s a visualization of the pathfinding data for the ground floor: https://tibiamaps.github.io/tibia-map-data/data/floor-07-path.png The lighter the color, the faster you can walk there.

Btw, related discussion: http://tibia.wikia.com/wiki/Talk:Administrator_Team#Mapper

Incomplete areas

Does anyone know what this area is & how to get there? https://tibiamaps.io/map#32906,31175,13:1 (check the floors above as well) It seems incomplete, and I’d love to explore it fully so the TibiaWiki mapper gets the full maps too.

Mathias from TibiaMaps.io (profile, talk) 17:16, June 3, 2016 (UTC)

Apparently it’s the quara spawn in Yalahar, and it’s already fully mapped (although there is no way to tell just by looking at the visual map). Gahh

Mathias from TibiaMaps.io (profile, talk) 18:25, June 3, 2016 (UTC)

The map is either missing the area at ferumbas ascendant for Zamulosh/Bashir; or I cannot find it. I need it to write spoilers for this seal/quest/puzzle.

Vario (talk) 02:28, June 11, 2016 (UTC)Vario Alert

Maps expanded, references changed

The map boundaries have been expanded with the Summer Update and apparently all links are wrong now. Is there any easy wait to fix that?

Molx (talk) 13:14, July 27, 2017 (UTC)

How do we know the map was expanded? Is there any new area outside of the old bounderies? The map version published by Cip to fansites has the same dimensions as before. I just sent a message to Mathias asking him about this. We would have to make some changes in order to adapt to the new dimensions.

Hunter of Dragoes (Talk · Contribs · Admins) - 14:02, July 27, 2017 (UTC)

Mathias removed the expansion, so this problem is solved, at least for now. But the images used in the "Minimap Zoom" are hosted in Wikia and aren't linked to TibiaMaps.io, they are still outdated. For example, check the Minimap zoom for Valindara, it's just water.

Molx (talk) 13:56, July 28, 2017 (UTC)